Ehren

Changing logo in header

Recommended Posts

By default, IPS.Suite 4.x uses your website name as it's logo. To use an image instead, go to Admin Cpanel > Customization > Themes > Edit > Logos

Next to Site Logo Image, upload your logo and press the Save button.

If you wish to revert back to a basic text logo, go back to the Logos page, toggle the Remove custom site logo switch, and press Save.

  • Like 5

Share this post


Link to post
Share on other sites
4 hours ago, Daifuku said:

Hello, 
how do I remove the logo completely? I don't want to have a logo displayed there if possible. :)
Greetings!

For your current theme (Chameleon), add the following to custom.css

#elSiteTitle{ display: none; }

 

Share this post


Link to post
Share on other sites
7 hours ago, Haunted said:

Hello,

 

I have a custom logo image, but would like to redirect it back to the home page of my site. Is there a way to do this in the admin panel somewhere?

You'd need to edit the URL of the link inside the logo template file. I think that's the only way. 

Share this post


Link to post
Share on other sites

Thanks for the reply! Can you please tell me where (what directory of the FTP) that would be located? Currently the logo just redirects to the forums. I didn't install the forum, but it's a custom logo in the header, and I am having trouble locating the file. 

Share this post


Link to post
Share on other sites

Thanks, Ehren. I appreciate the help. I am not very savvy with these types of things. Can you please tell me which part of the editor I would find this? This is what I see in the "Logo" section:

 

{{if \IPS\Theme::i()->logo['front']['url'] !== null }}
{{$logo = \IPS\File::get( 'core_Theme', \IPS\Theme::i()->logo['front']['url'] )->url;}}
<a href='{setting="base_url"}' id='elLogo' accesskey='1'><img src="{$logo}" alt='{setting="board_name" escape="true"}'></a>
{{else}}
<a href='{setting="base_url"}' id='elSiteTitle' accesskey='1'>{setting="board_name"}</a>
{{endif}}

Currently, the navigation is that clicking on the logo when the user is already at "www.websitename.com/forum" will just direct to "www.websitename.com/forum" which the "home" button already does in navigation menu. I would just like the logo to navigate back to "www.websitename.com" and am having trouble locating where to change this. 

Thanks in advance for any insight! :) 

Share this post


Link to post
Share on other sites
11 hours ago, Ehren said:

The image should be displayed if you've uploaded it via the Logo tab.

Use the System > Support feature in your ACP to clear your cache and see if that helps.

Sorry maybe I worded it wrong, what I want is no-logo and no-text or site name in my header at all. 

Share this post


Link to post
Share on other sites
2 hours ago, Ehren said:

Hello,

What theme are you using?

I'm using Default IPS theme.

My logo isn't center in the Mobile view. It's in right side. (My site's language is Persian and it's RTL )

Best Regards.

Share this post


Link to post
Share on other sites
3 hours ago, Behzad4x said:

I'm using Default IPS theme.

My logo isn't center in the Mobile view. It's in right side. (My site's language is Persian and it's RTL )

Best Regards.

I can't see your logo at all, even on desktop :unsure:

Share this post


Link to post
Share on other sites
On 25/10/2017 at 6:34 AM, Ehren said:

I can't see your logo at all, even on desktop :unsure:

Hello again,

Dear Ehren, now you must could see my logo in site, the problem is solved:

http://brokernews.ir

But my logo is not in center in mobile view.

Also my logo has low quality beside desktop. Quality in desktop is ok but in mobile it is blur.

Please help me to correct this problems. The support ips can't not solve this problems.

Regards.

Share this post


Link to post
Share on other sites
39 minutes ago, Behzad4x said:

But my logo is not in center in mobile view.

Also my logo has low quality beside desktop. Quality in desktop is ok but in mobile it is blur.

Add this to custom.css

@media (max-width: 767px){
  #elLogo{ display: block; text-align: center; }
}

 

I'm unsure about the low quality, sorry.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...