Jump to content

4.7.4: No theme updates necessary


Ehren
 Share

Recommended Posts

Hi there!

Following yesterdays release of Invision Community 4.7.4, I'm happy to announce no template updates are necessary for IPSFocus themes.

With that said, there will be a warning when upgrading which says that an upgrade is required for:

core > front > global > globalTemplate

While this is technically true (and usually warnings like this are valid and should be followed), it's safe to ignore for this update only. The code change simply involves removing a reference to an empty template file which isn't quite worthy of a new template update.

So just this once, you may safely ignore the warning and proceed with your upgrade! 🙂

Link to comment
Share on other sites

7 hours ago, Ehren said:

Hi there!

Following yesterdays release of Invision Community 4.7.4, I'm happy to announce no template updates are necessary for IPSFocus themes.

With that said, there will be a warning when upgrading which says that an upgrade is required for:

core > front > global > globalTemplate

While this is technically true (and usually warnings like this are valid and should be followed), it's safe to ignore for this update only. The code change simply involves removing a reference to an empty template file which isn't quite worthy of a new template update.

So just this once, you may safely ignore the warning and proceed with your upgrade! 🙂

My site delivers a 500 error Ehren.....just sent PM.

Link to comment
Share on other sites

On 11/3/2022 at 7:50 AM, XTremo54 said:

Now sorted with disabling third party addons and reinstalling Novus.

I tried this and am still getting an HTTP 500 Error.

I actually installed clean versions of Dimension Pro. I have quite a few theme modifications on my site so have a parent/child theme set-up and only updated the parent(s).

Additionally, I am a code idiot so no clue which of these errors might be actually related to the IPS Focus themes and which aren't. I currently have all 3rd party applications and plug-ins disabled.

Error: Undefined constant "IPS\Theme\raw" (0)
#0 /var/www/html/107404/applications/cms/sources/Blocks/Block.php(280): IPS\Theme\class_cms_block_RecordFeed->affiliates(Array, '1ad3c6aadba8a6f...', 'horizontal')
#1 /var/www/html/107404/system/Widget/Widget.php(234): IPS\cms\Blocks\_Block->getTemplate(Array, '1ad3c6aadba8a6f...', 'horizontal')
#2 /var/www/html/107404/system/Content/Widget.php(522): IPS\_Widget->output(Array, '1ad3c6aadba8a6f...')
#3 /var/www/html/107404/applications/cms/widgets/RecordFeed.php(312): IPS\Content\_Widget->render()
#4 /var/www/html/107404/applications/cms/sources/Blocks/Block.php(242): IPS\cms\widgets\_RecordFeed->render()
#5 /var/www/html/107404/applications/cms/widgets/Blocks.php(143): IPS\cms\Blocks\_Block::display(Object(IPS\cms\Blocks\Block), 'horizontal')
#6 /var/www/html/107404/system/Widget/Widget.php(833): IPS\cms\widgets\_Blocks->render()
#7 /var/www/html/107404/system/Widget/Widget.php(888): IPS\_Widget->_render()
#8 /var/www/html/107404/system/Theme/Theme.php(885) : eval()'d code(18547): IPS\_Widget->__toString()
#9 /var/www/html/107404/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_global->widgetContainer('footer', 'horizontal')
#10 /var/www/html/107404/system/Theme/Theme.php(885) : eval()'d code(6854): IPS\Theme\_SandboxedTemplate->__call('widgetContainer', Array)
#11 /var/www/html/107404/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_global->globalTemplate('4b1be58217d23c9...', '\n\n<div class='i...', Array)
#12 /var/www/html/107404/system/Dispatcher/Dispatcher.php(173): IPS\Theme\_SandboxedTemplate->__call('globalTemplate', Array)
#13 /var/www/html/107404/system/Dispatcher/Standard.php(113): IPS\_Dispatcher->finish()
#14 /var/www/html/107404/system/Dispatcher/Front.php(558): IPS\Dispatcher\_Standard->finish()
#15 /var/www/html/107404/init.php(927) : eval()'d code(37): IPS\Dispatcher\_Front->finish()
#16 /var/www/html/107404/system/Dispatcher/Dispatcher.php(155): IPS\Dispatcher\cloud_hook_ipsDispatcherFront->finish()
#17 /var/www/html/107404/index.php(13): IPS\_Dispatcher->run()
#18 {main}

Help me, Obi Wan Themnobi! You are my only hope! (I actually put in a post at Invision also).

Thanks in advance.

Link to comment
Share on other sites

59 minutes ago, Stormwolfe said:

I tried this and am still getting an HTTP 500 Error.

I actually installed clean versions of Dimension Pro. I have quite a few theme modifications on my site so have a parent/child theme set-up and only updated the parent(s).

Additionally, I am a code idiot so no clue which of these errors might be actually related to the IPS Focus themes and which aren't. I currently have all 3rd party applications and plug-ins disabled.

Errors should not be related to the theme at all. That is either a PHP version involved and/or third party items (even if disabled).

First confirm your PHP version. Then run Invision Community Requirements Checker 4.x. If you pass that then it is most likely that one of the disabled third-party items is still the issue. Yes, I saw that even disabled items were producing errors.

  • Thanks 1
Link to comment
Share on other sites

While still dead in the water, I have resolved the majority of the issues. We're down to it being a couple of non-vital plug-ins and one vital custom application. However, we're more or less functional.

Thank you all for your assistance and, most of all, patience.

  • Like 1
Link to comment
Share on other sites

On 11/3/2022 at 1:11 AM, Ehren said:

With that said, there will be a warning when upgrading which says that an upgrade is required for:

core > front > global > globalTemplate

 

Hi @Ehren

In the warning, I've also this :

core → front → global → userBar

Do you think it's safe ?

Link to comment
Share on other sites

5 hours ago, PersonalMode said:

Hi @Ehren

In the warning, I've also this :

core → front → global → userBar

Do you think it's safe ?

It sounds like you’re potentially upgrading from a version older than 4.7.3.

If you’re upgrading from 4.7.2 or anything earlier, you’ll need to upgrade your theme still (to the most recent one in the client area).

I hope there helps!  🙂 

Link to comment
Share on other sites

My apologies, version 4.7.2 is the most recent. 🙂

What software version were you upgrading from? I believe 4.7.2 required changes to the userBar template file, so if you're upgrading from a version prior to 4.7.2, that's the reason why you're getting that message.

Link to comment
Share on other sites

50 minutes ago, PersonalMode said:

I try to upgrade from 4.7.3 to 4.7.4

I wonder why some people were only warned about globalTemplate.. If you get the warning for userBar, visit the userBar template file once you've upgraded your software and find:

{{if \count(array_merge( $usernamePasswordMethods, $buttonMethods )) > 1}}

Change to:

{{if \count( $usernamePasswordMethods ) OR \count( $buttonMethods ) > 1}}

I'll have this fixed for the next update 🙂

 

Link to comment
Share on other sites

On 11/13/2022 at 7:07 PM, Ehren said:

I wonder why some people were only warned about globalTemplate.. If you get the warning for userBar, visit the userBar template file once you've upgraded your software and find:

{{if \count(array_merge( $usernamePasswordMethods, $buttonMethods )) > 1}}

Change to:

{{if \count( $usernamePasswordMethods ) OR \count( $buttonMethods ) > 1}}

I'll have this fixed for the next update 🙂

 

Sorry, but I'm a bit of a noob at this template stuff. How do I find this userbar template file?

I'll be honest, I was under the impression that my license with you covered new templates when they are required.

Link to comment
Share on other sites

3 hours ago, Tpasa said:

How do I find this userbar template file?

ACP > Customization > Themes > next to your theme select Edit HTML and CSS > swap from Simple to Advanced mode:

core > front > global > userBar

 

3 hours ago, Tpasa said:

I'll be honest, I was under the impression that my license with you covered new templates when they are required.

@Ehren clearly said that:

On 11/14/2022 at 1:07 AM, Ehren said:

I'll have this fixed for the next update 🙂

 

Link to comment
Share on other sites

11 hours ago, Tpasa said:

Sorry, but I'm a bit of a noob at this template stuff. How do I find this userbar template file?

I'll be honest, I was under the impression that my license with you covered new templates when they are required.

Hi Tpasa,

No worries - I've just updated the illuminate dark theme for you, so you can now download it in the Client Area. 🙂 

The 4.7.4 theme update is incredibly minor and has no breaking changes from the 4.7.2 update. To make upgrades a little less cumbersome for clients, I decided that a theme update wasn't necessary for this version as the code changes don't really provide any benefit to customers (this is the first time this decision was made).

Future theme upgrades will likely be released as normal.

I hope that helps!

Link to comment
Share on other sites

On 11/16/2022 at 3:23 PM, Ehren said:

Hi Tpasa,

No worries - I've just updated the illuminate dark theme for you, so you can now download it in the Client Area. 🙂 

The 4.7.4 theme update is incredibly minor and has no breaking changes from the 4.7.2 update. To make upgrades a little less cumbersome for clients, I decided that a theme update wasn't necessary for this version as the code changes don't really provide any benefit to customers (this is the first time this decision was made).

Future theme upgrades will likely be released as normal.

I hope that helps!

Excellent, thanks. 

Link to comment
Share on other sites

  • Ehren locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...