Jump to content

Theme updates for 4.6.8


Ehren
 Share

Recommended Posts

Hi everyone!

Yesterday, Invision Community 4.6.8 was released which required a minor update to themes due to new analytic settings. While this theme update isn't critical (you can continue using your existing theme with 4.6.8), it includes the new analytics code as well as a bunch of bug fixes:

  • The new analytic setting code introduced in the 4.6.8 software update has been addded
  • Long usernames are now truncated and will no longer stretch on top of the date in posts.
  • The notification badge on the “Cart” button in the user panel is now the correct width.
  • Activity Streams in clubs now have a background in certain themes, improving contrast.
  • Wrapped the content on the Cookie page with .ipsBox
  • Added “indent icons” to navigation dropdown menus, even if navigation icons are disabled.
  • The “Bookmark” button from the “Bookmarks” add-on is now styled correctly.
  • The floating checkbox panel in the Messenger now correctly sits on top of the mobile footer.
  • The pagination on search result pages is no longer hidden behind the results table in certain themes.

The updates are available now via the Client Area and Invision Marketplace!

  • Like 3
  • Thanks 3
Link to comment
Share on other sites

4 hours ago, Timberwolf said:

Hey @Ehren, with this update, we just update the theme, not upload the whole theme?

Yeah, if you’re already using the 4.5 or 4.6 version of the theme, you can safely use the “Upload new version” feature. 🙂 

If you’re using the 4.4 version still, a fresh theme installation is required due to the large amount of changes. 

  • Like 1
Link to comment
Share on other sites

1 hour ago, Ehren said:

Yeah, if you’re already using the 4.5 or 4.6 version of the theme, you can safely use the “Upload new version” feature. 🙂 

If you’re using the 4.4 version still, a fresh theme installation is required due to the large amount of changes. 

Excellent!  Thank you.

Link to comment
Share on other sites

On 11/4/2021 at 12:15 AM, Ehren said:

Yeah, if you’re already using the 4.5 or 4.6 version of the theme, you can safely use the “Upload new version” feature.

Just as a matter of standard procedure ...

Is it preferable to do the Invision update first and then upload the new theme version 

or

upload the new theme version and then the do the Invision 4.6.8 update

or

it makes no difference

Link to comment
Share on other sites

I'd typically suggest upgrading your forum software first, followed by the theme.

The reason for this is that new code or features are sometimes introduced with software updates (such as Achievements in 4.6). If you upgrade your software first, the worst case scenario is that the feature simply isn't visible on your site, until you upgrade your theme.

However, if you upgrade the theme first (and if the updated theme includes "Achievements code"), your software won't understand the code since that feature doesn't exist in the software yet, and it will potentially show an error on your frontend.

It's not a super strict process, but "software upgrade first" seems safest in most situations 🙂

Link to comment
Share on other sites

I'm using Chameleon and updated Chameleon in preparation for the forum software update. 

I Created a skin with Chameleon as a parent so the forum is still using old version of Chameleon and not updated yet.

When I started the software update, it warned me that both the old and updated versions of Chameleon were incompatible in many places with 4.6.8

What should I do? I looked at the differences in the updated Chameleon compared to 4.6.8 that made it incompatible and the list was quite long.

 

Link to comment
Share on other sites

2 hours ago, TheWellman said:

I'm using Chameleon and updated Chameleon in preparation for the forum software update. 

I Created a skin with Chameleon as a parent so the forum is still using old version of Chameleon and not updated yet.

When I started the software update, it warned me that both the old and updated versions of Chameleon were incompatible in many places with 4.6.8

What should I do? I looked at the differences in the updated Chameleon compared to 4.6.8 that made it incompatible and the list was quite long.

 

Hello,

The upgrade script simply checks themes to see if certain template files have been modified. With the 4.6.8 update, changes were made to the "globalTemplate" file. Since this file is modified in the Chameleon theme, the software is simply guessing that it's outdated - it doesn't actually check the code to see if it's compatible with the new version or not. The "warning" you're seeing with the new version of Chameleon can be ignored since the new theme is using updated code already.

The correct process for upgrading themes is to typically upgrade the forum software first, followed by the theme. 🙂

  • Thanks 1
Link to comment
Share on other sites

  • Ehren locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...