Ehren

All themes upgraded for 4.6.0

Recommended Posts

Following the release of Invision Community 4.6.0 last week, I'm happy to announce all IPSfocus themes have also been updated for 4.6.0!

Current subscribers can download the 4.6.0 version of the themes from the Client Area or from the Invision Marketplace. If your subscription has expired, renewals are priced at $10 USD, which provide access to theme updates for the next 6 months.

Note: This 4.6 theme update should only be used with Invision Community 4.6. It is not compatible with Invision Community 4.5.x. You should upgrade your software first before upgrading your theme.

This update includes numerous bug fixes as well as support for the new achievements feature in 4.6. For those interested, here's the full change log of updates which have been added to all themes:

  • Upgraded for Invision Community 4.6.0
  • Added a background to the content box on the Privacy Policy page
  • The Customizer now correctly states “Snow” or “Hearts” instead of “Confetti” if any a full-screen effect is enabled.
  • In certain themes, a background has been added to the inbox page when no message is selected.
  • The inbox folder select menu now works correctly in Chrome.
  • The background of the “We value your feedback” modal is no longer white dark themes.
  • The Recommended Posts title now has better contrast in certain theme.
  • If the Background Picker is restricted from certain user groups, those groups can no longer scroll across the image options.
  • The “Disable my inbox” text no longer falls behind the Messenger inbox list.
  • The “last post date” on the index page on mobiles now uses a slightly larger font-size.
  • “Compact” Activity Stream items now have a little extra padding in certain themes.
  • Removed domain extensions from the social icons css selectors.
  • The RSS link on Activity Streams on mobiles now has better contrast.
  • Certain Activity Stream items now correctly have a margin to separate them.
  • Padding in topic list rows now matches the padding on the forum index rows.
  • The “Disable my messenger” link is now easier to read in certain themes.
  • The “Insert Code” modal box is now coloured correctly in dark themes.
  • Autofill in chrome no longer shows a light blue input in dark themes.
  • The “All followers” page now has a background colour applied for improved contrast.
  • Added “Whats App” to the Social Icons.
  • The Activity Stream dropdown menus are no longer covered by other elements in certain themes while using Safari.

Enjoy! :)

  • Like 3
  • Thanks 3

Share this post


Link to post
Share on other sites

Amazing work Ehren! Thank you for the quick updates!

  • Like 1

Share this post


Link to post
Share on other sites

That was fast, thanks Ehren 👌

Do you have time to upgrade custom themes atm?
I'd have to send you my custom.css beforehand though...
 

Share this post


Link to post
Share on other sites
21 minutes ago, bosss said:

Thanks for update @Ehren

Can we use 4.6 theme on IPS 4.5?

No, the 4.6 theme has achievements logic which will likely break in 4.5.

Use the 4.5 theme if you’re on 4.5 ;) 

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, ThomasP said:

That was fast, thanks Ehren 👌

Do you have time to upgrade custom themes atm?
I'd have to send you my custom.css beforehand though...
 

Yeah, the 4.6 update is pretty simple so just email me whenever you’re ready 🤝

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm getting a template error on Titan both on 4.6.0.

Error is to do with mobileNavigation (All apps/plugins are currently disabled.

Share this post


Link to post
Share on other sites
2 hours ago, Dean_ said:

I'm getting a template error on Titan both on 4.6.0.

Error is to do with mobileNavigation (All apps/plugins are currently disabled.

Have you upgraded or installed as like a new theme?

Share this post


Link to post
Share on other sites
22 minutes ago, Feneroin said:

Have you upgraded or installed as like a new theme?

Indeed, I do a fresh install with every update, force of habit. I'll check the code and see what's happening.

Share this post


Link to post
Share on other sites

Yup there's an issue @Ehren my site is unusable via Mobile. While using it and pressing the burger menu, it just adds a highlighted contrast to the screen and no menu shows, freezing the site. Only closing the site can you then navigate the site.
 

[[Template core/front/global/mobileNavigation is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

 

Error: Call to undefined method IPS\core\extensions\core\FrontNavigation\MenuHeader::link() in /home2/<--SNIP-->/public_html/uploads/template_54_94a9d7649fb9cdbfc784d3516e61a717_global.php:9707 Stack trace: #0 /home2/<--SNIP-->/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\Cache\class_core_front_global->mobileNavigation() #1 /home2/<--SNIP-->/public_html/uploads/template_54_94a9d7649fb9cdbfc784d3516e61a717_global.php(6789): IPS\Theme\_SandboxedTemplate->__call('mobileNavigatio...', Array) #2 /home2/<--SNIP-->/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\Cache\class_core_front_global->globalTemplate('<--SNIP-->...', '\n\n<div class='i...', Array) #3 /home2/<--SNIP-->/public_html/system/Dispatcher/Dispatcher.php(173): IPS\Theme\_SandboxedTemplate->__call('globalTemplate', Array) #4 /home2/<--SNIP-->/public_html/system/Dispatcher/Standard.php(113): IPS\_Dispatcher->finish() #5 /home2/<--SNIP-->/public_html/system/Dispatcher/Front.php(670): IPS\Dispatcher\_Standard->finish() #6 /home2/<--SNIP-->/public_html/system/Dispatcher/Dispatcher.php(155): IPS\Dispatcher\_Front->finish() #7 /home2/<--SNIP-->/public_html/index.php(13): IPS\_Dispatcher->run() #8 {main}

 

Share this post


Link to post
Share on other sites
2 hours ago, Dean_ said:

Yup there's an issue @Ehren my site is unusable via Mobile. While using it and pressing the burger menu, it just adds a highlighted contrast to the screen and no menu shows, freezing the site. Only closing the site can you then navigate the site.
 


[[Template core/front/global/mobileNavigation is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

 


Error: Call to undefined method IPS\core\extensions\core\FrontNavigation\MenuHeader::link() in /home2/<--SNIP-->/public_html/uploads/template_54_94a9d7649fb9cdbfc784d3516e61a717_global.php:9707 Stack trace: #0 /home2/<--SNIP-->/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\Cache\class_core_front_global->mobileNavigation() #1 /home2/<--SNIP-->/public_html/uploads/template_54_94a9d7649fb9cdbfc784d3516e61a717_global.php(6789): IPS\Theme\_SandboxedTemplate->__call('mobileNavigatio...', Array) #2 /home2/<--SNIP-->/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\Cache\class_core_front_global->globalTemplate('<--SNIP-->...', '\n\n<div class='i...', Array) #3 /home2/<--SNIP-->/public_html/system/Dispatcher/Dispatcher.php(173): IPS\Theme\_SandboxedTemplate->__call('globalTemplate', Array) #4 /home2/<--SNIP-->/public_html/system/Dispatcher/Standard.php(113): IPS\_Dispatcher->finish() #5 /home2/<--SNIP-->/public_html/system/Dispatcher/Front.php(670): IPS\Dispatcher\_Standard->finish() #6 /home2/<--SNIP-->/public_html/system/Dispatcher/Dispatcher.php(155): IPS\Dispatcher\_Front->finish() #7 /home2/<--SNIP-->/public_html/index.php(13): IPS\_Dispatcher->run() #8 {main}

 

The mobileNavigation template file is unmodified in all of my themes (which are all working correctly on my demo site). Have you modified that template file on your site?

If so, you'll need to either revert it and reapply your modifications, or manually update it using the "difference report".

Share this post


Link to post
Share on other sites
15 hours ago, Ehren said:

Yeah, the 4.6 update is pretty simple so just email me whenever you’re ready 🤝

Are you available for custom work?

Share this post


Link to post
Share on other sites
2 hours ago, David.. said:

Are you available for custom work?

Only if you're happy to wait a while. I'm currently in the middle of a large redesign for the Invision website, so I'm not sure when I'll be available for custom themes yet.

Share this post


Link to post
Share on other sites
8 hours ago, Ehren said:

The mobileNavigation template file is unmodified in all of my themes (which are all working correctly on my demo site). Have you modified that template file on your site?

If so, you'll need to either revert it and reapply your modifications, or manually update it using the "difference report".

Nothing at all Ehren, I’ve re-downloaded the theme once again last night (now morning for me) and I got the same issue. 
I’ll investigate more and see if turning off any plugins etc has caused issues. But I’ve edited nothing.

Share this post


Link to post
Share on other sites

Do you recommend "Upload a new version", or deleting the old version and uploading from the beginning?

Thank you

Share this post


Link to post
Share on other sites
12 hours ago, Square Wheels said:

Do you recommend "Upload a new version", or deleting the old version and uploading from the beginning?

Thank you

If you were using the 4.5 version, then “Upload new version” should work fine.

If you’re upgrading from 4.4 or less, install it as a fresh theme. 

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, Dean_ said:

Nothing at all Ehren, I’ve re-downloaded the theme once again last night (now morning for me) and I got the same issue. 
I’ll investigate more and see if turning off any plugins etc has caused issues. But I’ve edited nothing.

Send me a PM with a username and password to your ACP and I’ll take a look for you :) 

  • Like 1

Share this post


Link to post
Share on other sites

Now is IPS 4.6.1 out - are there theme changes?

Share this post


Link to post
Share on other sites
9 hours ago, bosss said:

Now is IPS 4.6.1 out - are there theme changes?

I've upgraded my forum and no problem with Wireless theme

  • Thanks 1

Share this post


Link to post
Share on other sites
22 hours ago, Ehren said:

Send me a PM with a username and password to your ACP and I’ll take a look for you :) 

4.6.1 has just corrected the issue for me. Looks like Feneroin's issue has been fixed too.

Share this post


Link to post
Share on other sites

I believe 4.6.1 is simply a patch to fix certain software/upgrade issues. No theme updates are needed :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now