Ehren

4.1.17 theme updates

Recommended Posts

All ipsfocus themes have been upgraded and released for IPS.Suite 4.1.17. The update is fairly critical and includes compatibility for new features such as the leaderboard.

Customers can download the updated themes from their Client Area! :)

  • Like 5

Share this post


Link to post
Share on other sites
2 minutes ago, Ehren said:

All ipsfocus themes have been upgraded and released for IPS.Suite 4.1.17. The update is fairly critical and includes compatibility for new features such as the leaderboard.

Customers can download the updated themes from their Client Area! :)

(That you know of) Have IPS fixed that bug yet with updating themes, IE: Does it still have to be a fresh install of the theme rather than "Upgrade"?

 

Share this post


Link to post
Share on other sites
12 minutes ago, Ero-Neko said:

(That you know of) Have IPS fixed that bug yet with updating themes, IE: Does it still have to be a fresh install of the theme rather than "Upgrade"?

 

I have no idea - I've never used the feature myself :)

  • Like 1

Share this post


Link to post
Share on other sites

Ahh jeez, didn't even think an issue like that would happen. The IPS dev's should use existing colours from the theme settings instead of hard coding them - doing so would prevent issues like this!

It's 2:00am local time so I'll fix it first thing in the morning!

  • Like 1

Share this post


Link to post
Share on other sites

Adding to the above, it appears that a lot of the css doesn't get loaded, even custom css. It only works in designer mode, and is only happening on the dimension skin. On the default and other custom skins we have it's fine. 

Share this post


Link to post
Share on other sites

Got it looking relatively okay using custom css for the meantime on spectrum. 

2016-12-06_17-34-03.png

.cPastLeaders_cell { 	background: rgba(0,0,0,0.2); }
.cPastLeaders_cell:after  { color: white; }
.cPastLeaders_cellEmpty { 	background: rgba(0,0,0,0.2); }
.cPastLeaders_title span { background: transparent; }

 

  • Like 1

Share this post


Link to post
Share on other sites

Numerous bugs have been fixed on my demo board, including improvements to the breadcrumb navigation (which is now pure css instead of images) and the Profile page on mobiles and tablets. The leaderboard has also been fixed in all themes.

I'll let the changes sit for a while to make sure there are no further bugs - then I'll export all themes in a few hours at which point they'll be available to download!

  • Like 3

Share this post


Link to post
Share on other sites
6 hours ago, Ehren said:

Numerous bugs have been fixed on my demo board, including improvements to the breadcrumb navigation (which is now pure css instead of images) and the Profile page on mobiles and tablets. The leaderboard has also been fixed in all themes.

I'll let the changes sit for a while to make sure there are no further bugs - then I'll export all themes in a few hours at which point they'll be available to download!

Have they been uploaded too invisionpower's marketplace? Didn't get any new version notification from them. 

Share this post


Link to post
Share on other sites
12 minutes ago, EnigmaPatrick said:

Have they been uploaded too invisionpower's marketplace? Didn't get any new version notification from them. 

They'll be uploaded there shortly :)

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, EnigmaPatrick said:

 

Great, thanks! Are there any other remaining issues left to be fixed?

Not that I'm aware of :) The marketplace files have just been updated.

Share this post


Link to post
Share on other sites
8 minutes ago, EnigmaPatrick said:

It's still happening: 

Capture.PNG

Feel free to use your existing support topic if you still need help, since support isn't offered in the News forum :)

Share this post


Link to post
Share on other sites
On 12/6/2016 at 7:37 AM, Ero-Neko said:

(That you know of) Have IPS fixed that bug yet with updating themes, IE: Does it still have to be a fresh install of the theme rather than "Upgrade"?

 

I have been doing the "update" method for the past few theme updates ... no issues that I have noticed.

Share this post


Link to post
Share on other sites
On 9 Dec 2016 at 2:38 AM, autumnwalker said:

I have been doing the "update" method for the past few theme updates ... no issues that I have noticed.

I tried this myself last weekend. First updated my test forum (after of course making backups of forum and DB's) then when I didn't see anything going wrong on my test forum, I updated my main forum through IPS update.

It worked like a charm. 


Just make sure you have backups of everything before you skip the manual update, what works for me or 'autumwalker' may not work for your specific board.
Still, What a relief! No more manual skin updates...  whoop,whoop! *\o/*

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.